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Exercise No. 1
Introduction to GIS Software

Objective: To understand the basics of Geographic Information System (GIS) software, its
components, and its applications in agriculture.

What is GIS?

A Geographic Information System (GIS) is a tool used to capture, store, manipulate, analyze,
manage, and present spatial or geographic data. In agriculture, GIS helps in mapping fields,
analyzing soil types, and planning crop management.

Components of GIS Software
GIS software typically consists of the following components:

1. Hardware: Computers and GPS devices used to collect and store data.
Software: Applications used to process and analyze geographic data.
Data: Geographic data layers, including maps, satellite images, and tables.
People: Users who input data and interpret results.

. » W DN

Methods: Procedures and techniques for data analysis.

Key Functions of GIS Software

1. Data Input: Importing data from various sources such as GPS devices, satellites, and
manual entry.

2. Data Storage: Organizing and storing spatial data in databases.
Data Manipulation: Editing and modifying data layers.

4. Data Analysis: Performing spatial analysis such as buffering, overlay, and proximity
analysis.

5. Data Output: Generating maps, reports, and charts.

Basic Operations in GIS Software
Step-by-step guide to performing basic operations using GIS software:
1. Start the GIS Software: Open the GIS software application on your computer.
2. Load Data: Import spatial data files (e.g., shapefiles, raster images).
3. View and Explore Data: Use the software tools to explore the data layers and
understand their attributes.
4. Edit Data: Make necessary edits to the spatial data, such as updating field boundaries
or correcting errors.
5. Analyze Data: Perform analysis such as buffering or overlay to understand spatial
relationships.
6. Save and Export Results: Save your project and export maps or reports as needed.
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Table 1: Common GIS Software

supporting various data

maps for agriculture.

Open

Sr. Name of GIS . Platform Possible Use in P

Details . Access
No. Software Used Agriculture .
or Paid
A free and open-source GIS Mapping, soil analysis,
QGIS (Quantum ¢ andopen-sou _ PpIng, SOL analy
) application that supports Windows, | crop monitoring,
Geographic _ o . . Open
1 , spatial data visualization, macOS, precision farming,
Information . . . . . Access
System) editing, and analysis. It has Linux creating thematic
y extensive plugin support. maps.
GRASS GIS
. An open-source GIS software . Soil erosion modeling,
(Geographic ) ) Windows, i
suite for geospatial data land-use planning, Open
2 Resources . macOS, .
, management, analysis, and , crop productivity Access
Analysis Support . . Linux .
spatial modeling. analysis.
System)
SAGA GIS (System | An open-source GIS with a Windows Terrain analysis, soil
W ) . .

3 for Automated strong focus on raster data macOS mapping, crop yield Open
Geoscientific processing and spatial Linux ’ modeling, Access
Analyses) analysis. hydrological analysis.

SIG (G litat Precision farming,
gv ( eneralitat | , open-source desktop GIS . rec151on.arr.nmg
Valenciana i ) , Windows, | crop monitoring,
. developed in Spain, offering i : Open
4 Geographic e i ) macOS, environmental impact
. capabilities for working with . . Access
Information Linux assessments in
both vector and raster data. .
System) agriculture.
ILWIS (Integrated | An open-source GIS and Land use and land
5 Land and Water remote sensing software with Windows cover analysis, soil Open
\
Information tools for spatial analysis and moisture estimation, Access
System) image processing. agricultural mapping.
Soil and wat
Whitebox GAT An open-source GIS with a . oran w.a er
. . Windows, conservation, land use
(Whitebox focus on geospatial data ) ; Open
6 . . . macOS, planning, terrain
Geospatial analysis and hydrological ) ) Access
) . Linux analysis for
Analysis Tools) modeling. )
agriculture.
Envi tal
An open-source GIS nv1r0nr.nen 2
application with tools for data monitoring, water Open
7 MapWindow GIS pp L. . Windows resource
visualization, editing, and . Access
. . ) management, basic
analysis, supporting plugins. ) :
agricultural mapping.
Web-based
A free open-source JavaScript . .
. . . . agricultural mapping,
library for displaying maps in ]
) real-time farm data Open
8 OpenLayers web browsers, supporting Web-based . L
. visualization, Access
various map formats and )
environmental
sources. o
monitoring.
F tl
. An open-source GIS . arrr.l r.nanage.men
uDig (User- o Windows, precision agriculture,
] application focused on ease of , ) : Open
9 friendly Desktop . o macOS, integration with
use and internet connectivity, , ] . Access
Internet GIS) , ] Linux online spatial data
built on Eclipse RCP.
sources.
Dissemination of
An open-source server for agricultural geospatial | Open

10 | GeoServer sharing geospatial data, Web-based | °© ) B p p

data, creating online Access
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Sr. Name of GIS . Platform Possible Use in pen

Details . Access
No. Software Used Agriculture .
or Paid
formats and services like WMS,
WEFS, and WCS.
A comprehensive GIS software Precision agriculture,

11 | Arcars suite b.y Esri fo.r spatial Windows, | yield predic.tior.l, crop. Paid
analysis, mapping, and data macOS health monitoring, soil
management. fertility mapping.

Farm management,
A desktop GIS software by & .
i : land-use planning,
MaplInfo Pitney Bowes known for its . . )
12 , , ) Windows spatial data Paid
Professional ease of use in spatial data ) .
, , visualization for
analysis and mapping. )
agriculture.
) L Crop classification,
A remote sensing application monitorine land use
13 | ERDAS IMAGINE with tools for raster data Windows & ) Paid
. . . changes, analyzing
processing and image analysis. >
satellite imagery.
ENVI A remote sensing software for Vegetation analysis,
, processing and analyzing Windows, | crop health
(Environment for o . o .
14 Visualizin geospatial imagery, strong in macOS, monitoring, land cover | Paid
& image analysis and spectral Linux classification, yield
Images) .
data. forecasting.
A GIS application that offers a Terrain analysis, field

15 | Global Mapper wide range of data pro'cessing Windows bou.ndary mapping, Paid
tools and supports various environmental impact
spatial data formats. analysis in farming.

A GIS software developed by Farm infrastructure
Autodesk that int tes GIS 1 ing, land-

16 | AutoCAD Map 3D | - odeskcrnatintegrates Windows | P anmng fand-use Paid
data with CAD-based planning, precision
workflows. irrigation design.

A GIS software developed by
e Land management,
GE Energy, used by utilities Windows infrastructure
17 | Smallworld GIS and telecommunications i ' , . Paid

, i Linux planning, precision
companies for managing . o
, farming applications.
infrastructure.

Land

A GIS software integrated with and fesource
Bentley Systems' suite of management,

18 | Bentley Map i , , Windows agricultural facility Paid

infrastructure engineering ) ,
design, spatial data
tools.
management.
A remote sensing and GIS Crop health
software suite developed by : monitoring, land cover
. . . Windows, o )

19 Geomatica PCI Geomatics with tools for Linux classification, Paid
image analysis and spatial precision farming
modeling. analysis.

A GIS software developed by Agricultural market
20 | Maptitude Caliper Corporation, known for Windows analysis, farm Paid

its user-friendly interface and
powerful mapping tools.

planning, spatial
analysis of crop data.
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Assignment for students
1. Describe what is a Geographic Information System (GIS) is and show its main
components in diagram form.

2. Explain how GIS can be used in agriculture.
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Exercise No. 2
Basic Learning of QGIS Software

Objective: To introduce students to the basic functions of QGIS, including creating a new
project, adding data, and performing simple analyses.

1. Installing QGIS:
Download and Install: Go to the QGIS official website and download the latest version

suitable for your operating system.
Follow the installation instructions provided on the website.
2. Downloading Sample Data

Download the sample data from https://github.com/qgis /QGIS-Sample-
Data/archive/master.zip and unzip the archive on any convenient location on your system.

The Alaska dataset includes all GIS data that are used for the examples and screenshots in this
manual; it also includes a small GRASS database. The projection for the QGIS sample datasets
is Alaska Albers Equal Area with units in feet. The EPSG code is 2964.

3. Starting QGIS:
Open QGIS: Launch the QGIS application from your desktop or start menu.
Create a New Project: Click on “New Project” from the File menu to start with a blank
canvas.

Q qgil‘v Desktop 3.26.3
& 0 Apps Documents Web Settings Folders Photos » A e '.

Best match

2
. QGIS Desktop 3.26.3 \
I (“\% App k\‘

Search the web QGIS Desktop 3.26.3
App

Q, qgi - See more search results >

cas QGIS > (7 Open
Q_ qgis download >

Q qgis 3.14 > Recent

& world
Q_ qgis tutorial > 5

{2} QGIS Introduction Practical Exercise
Q_ qgis software >

Apps

~ Qt Designer with QGIS 3.26.3
* custom widgets

Folders

QGIS 3.26.3 >
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4. Setting Up Your Project:

Set Coordinate Reference System (CRS):
Click on the “Project” menu, then select “Properties”.
Go to the “CRS” tab and select the appropriate Coordinate Reference System for
your data (e.g., WGS 84 for global data).

Save Your Project:
Save your project regularly by clicking “File” and then “Save Project”. Name
your project file and choose a location on your computer.

(@ Untitled Project — QGIS

= o X
Preje(! Edit View Layer Settings Plugins Vector Raster Database Web Mesh Processing Help
[ 3] T A 1 =
| B New ikl >4 BatDOR A RyrE QE T Eom-§ i
New from Template > =
| - g = @@ e H
Qpen... Ctri+0 3, Lae B
Open From >
Open Recent >
Close
E seve Ctrl+s
B save As... Ctrl+Shift+S
Save To »
Revert...
J Properties.. Ctrl+Shift+P
Snapping Options...
Import/Export >
3 New Print Layout... CtrisP
) New Report..
4 Layout Manager...
Layouts >
Models »
Exit QGIS Cri+Q
Q Typeto Ready Coordinate| 0.899,-2.165 ¥ Scale|1:1223536 ~ | g Magnifier| 100% 2| Rotation |0.0° 3 Vi Render @epscaze @
a 28°C = - - ol & ENGIVS e 11:57
Mostly sunny mm Q Search WV E - a 2 e 5’ i Q ~ 8 VIR Y 27-08.2024 B
Q Untitled Project — QGIS
y os @ © 5 p= o mm - = P
0 BREHK [0 Ll Y o 78 | @ Project Properties — CRS X
BQV.Z BB L > {Q | Project Coordinate Reference System (CRS)
v k. Gareral No CRS (or unknown/non-Earth projection)
] Filter | Q
: | Q
¥, B vescan
Recently Used Coordinate Reference Systems
& View Settings Coordinate Reference System Authority 1D
% WGS 84 EPSG:4326
I
£ Transformations
")
¥ Styles
Q- ¥ sy
@R B8 Data sources
&) B Relations
& . »
£l Variables
V. Predefined Coordinate Reference Systems Hide deprecated CRSs
°® Macros Coordinate Reference System Authority ID A
WGS 66 EPSGi4760
=7 QGIS S
=5 QGl5 Server WGS 66 EPSG:4891
& Termporal WGS 72 EPSGi4322
WGS 72 EPSGi4985
A Terrain WGS 72BE EPSGi4324
WGS 72BE EPSGi4987
WGS 84 EPSG4326
WGS 84 EPSGi4979 2
‘ »
WGS 84 -
Properties “&Kmﬁ\/:« R
» Geographic (uses latitude and longitude ~ " LR
for coordinates) 5 o %
* Dynamic (relies on a datum which is not S S A A'f‘,‘
plate-fixed) ¥ (= R
« Celestial body: Earth v 3 Y 2
« Based on Worid Geodetic System 1984 . B
ensemble (EPSG:6326), which has a £
limited accuracy of at best 2 meters. ~
oK. Cancel Apply Help
Q_ Type to locate (Ctri+; Coordinate| 1.721,2.770 | Scale 1:1213732 + & Magnifier| 100% < Rotation |0.0° 3+ v/ Render @epsciazze @
28°C ] - - G G ENG 12:00
ety sunng W Q Search D u BB e dOHQ AN RDO a0, B
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5. Adding Data Layers:

Add Vector Data:
Click on the “Layer” menu, select “Add Layer” and then “Add Vector Layer”.
In the dialog box that appears, click “Browse” to locate your vector data file (e.g.,
shapefile or GeoJSON).
Select the file and click “Open” to add it to the map.

Add Raster Data:
Click on “Layer”, then “Add Layer” and choose “Add Raster Layer”.
Browse to locate your raster data file (e.g., satellite imagery) and click “Open”.

@ *QGIS Introduction Practical Exercise — QGIS = -] X
Project Edit View Settings Plugins Vector Raster Database Web Mesh Processing Help
B R % Data Source Manager Ctri+L \ e L QR a0 @ e T =
T Create Layer > ~7
BV A == Qa® & B
Add Layer B V- Add Vector Layer... Ctrl+Shift+V | i
Embed Layers and Groups. “% Add Raster Layer... Ctrl+Shift+R
Add from Layer Definition File... B Add Mesh Layer.
i Georeferencer. 9, Add Delimited Text Layer... Ctrl+Shift+T
c @, Add PostGIS Layers. Ctrl+Shift+D
/£, Add Spatialite Layer... Ctri+Shift+L
B Add MSSQL Spatial Layer.
Add Oracle Spatial Layer.. Ctrl+Shift+O

B, Add SAP HANA Spatial Layer.

¥4 Add/Edit Virtual Layer...

% Add WMS/WMTS Layer. Ctrl+Shift+W
£55 Add XYZ Layer.

€ Add WCS Layer.

&) Add WFS Layer.

& Add ArcGIS REST Server Layer.

B, Add Vector Tile Layer.

4 Add Point Cloud Layer.

‘

SEDHABNLHES

1 Remove Layer/Group ctri+D

©0 Show All in Overview

g Hide All from Overview

1 legend entries removed. Coordinate | -9724054,10773631 | Scale|:15345607 ¥ | @ Magnifier| 100% % | Rotation |0.0° +| v Render @epscioes @
30°C ] - = 5 ENG 4 16:07
& Mostly sunny mm  Q Search D e BRe dQ A T D® 0 R

6. Exploring Data Layers:
View and Zoom:
Use the navigation tools (pan, zoom in/out) to explore your data.
Click on the “Zoom In” or “Zoom Out” buttons on the toolbar or use your mouse
scroll wheel.
Layer Properties:
Right-click on a layer in the “Layers” panel and select “Properties”.
Explore the tabs for information about the layer’s symbology, metadata, and
attributes.
7. Basic Map Operations:
Identify Features:
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Use the “Identify Features” tool (an icon with a blue “i”) to click on a feature on
the map and view its attributes.
Label Features:

Right-click on a layer, choose “Properties”, and go to the “Labels” tab.
Check “Label this layer with” and select an attribute to display labels on the
map.
8. Performing Simple Analysis:
Creating a Buffer:

Select the “Vector” menu, then “Geoprocessing Tools”, and choose “Buffer”.
In the dialog box, select the input layer and set the buffer distance. Click “Run”
to create a buffer around your features.

Saving and Exporting:
Save your changes by clicking “File” and “Save Project”.
Export your map by clicking “Project” and selecting “Import/Export”, then
“Export Map to Image” to save it as an image file (e.g., PNG or JPEG).

9. Closing QGIS:
Save Your Work:

Ensure you have saved your project and any changes made.
Click “File” and “Exit” to close QGIS.

Creation of layers:

Creation of layers can be done with “Create Layer” menu, from which, any type of data, e.g
raster or vector can be inserted as shown in the figure given below. For thid “Tougle Editing”
(pencil icon) then “Add point future” (for adding the vector data in point form) is used.

Q @ New Shapefile Layer X

T BnEY (e 2HDF 2 File name Airports
= = File encoding UTF-8
>\ 2
®e 4 B Geometry type No Geometry

Additional dimensions Point l

Linestring ‘

New Field Polygon

Name
Type | abeText (string)

Length 80 Precision

“«

Fields List

Name Type Length Precision
id Integer 10

AHDABNLENS

< &
3 &
‘

7

Cancel Help Magnifier| 100% % Rotation 0.0° +| IV Render @epsci2o6s @
2r°c . = - - P, NG 1929
Partly cloudy mm  Q Search v L = B H e Q & AR T RD® o0 B
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Assignment for students
1. Draw a flow-diagram for explaining the procedure from installation of QGIS to
adding various layers, identification of features.
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Exercise No. 3

Understanding the Spatial Data Types in GIS and
Adding and Creation of Data in QGIS

Objective: To introduce students to the basic spatial data types for using in GIS

To study the process of add and create the data in QGIS

Vector and raster data represent spatial information in different ways in GIS.
A. Vector Data

1.

Representation: Vector data represents geographic features using geometric shapes.
These features are stored as points, lines, and polygons.
i. Points: Represent specific locations (e.g., wells, landmarks).

ii. Lines: Represent linear features (e.g., roads, rivers).

iii. Polygons: Represent area features (e.g., lakes, land parcels).
Data Structure: Vector data uses coordinates to define the shape and location of
features. Each feature is associated with a set of attributes stored in a table.
Data Precision: Vector data is precise and can represent exact boundaries and
locations. It is suitable for mapping discrete features with well-defined edges.
Data Size: Vector data generally has a smaller file size compared to raster data because
it stores only the coordinates and attributes of features.
Analysis: Vector data is well-suited for tasks that require exact boundaries and detailed
attribute analysis, such as network analysis, overlay analysis, and buffering.
Examples: Administrative boundaries, transportation networks, and land use areas.
Visualization: Vector data allows for smooth scaling and high-resolution rendering of
features.

B. Raster Data

1.

Representation: Raster data represents geographic information as a grid of cells or
pixels, where each cell has a value representing a characteristic (e.g., temperature,
elevation).

Data Structure: Raster data consists of a matrix of cells arranged in rows and columns.
Each cell has a specific value and is referenced by its row and column position.

Data Precision: Raster data is less precise than vector data as it represents information
in a grid format, which can lead to pixelation and loss of detail in large-scale analysis.
Data Size: Raster data can have a larger file size, especially for high-resolution images,
because it stores information for every cell in the grid.

Analysis: Raster data is suitable for continuous data analysis and modeling, such as
surface analysis, interpolation, and suitability modeling.

Examples: Satellite imagery, digital elevation models (DEMs), and land cover
classifications.

11
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7. Visualization: Raster data can represent gradual changes and patterns (e.g., elevation

gradients, temperature variations) and is typically visualized using color gradients or

shading.

Table 1. Differences in vector and raster data

SN | Aspect Vector Data Raster Data
1 | Representation | Points, lines, polygons Grid of cells or pixels
2 Data Structure | Coordinates and attributes Matrix of cell values
3 Precision High precision with exact boundaries Lower precision, pixelated representation
4 | File Size Generally smaller Generally larger
> Analysis Discrete feature analysis (overlay, buffer) C.ontlnuous. surface analysis
(interpolation)
Examples Roads, boundaries, land use areas Elevation maps, satellite imagery
7 Visualization Smooth scaling, detailed features Color gradients, shaded representations

Table 2. Common file formats used for vector and raster data in QGIS
Type File Format Extension | Description Usage
) Stores geometric location and | Commonly used for vector
Shapefile .shp . . .
attribute information. data layers.
A JSON f t f di
Geo]SON eojson Var]iet Z;ma eoor;'ae?l(i:: mdgat: Useful for web applications
'8€0) Y geograp and data interchange.
structures.
XML format for representing
Used for Google Earth and
KML/KMZ kml / kmz | geographic data. KMZ is a sed for .oog ¢ harth an
) web mapping.
Vect compressed version of KML.
ector
GML ml XML format for expressing | Used for complex geospatial
B geographical features. data and interoperability.
Drawing Exchange Format for CAD | Used for engineering and
DXF dxf )
data. architectural data.
Maplnfo TAB tab Format.used by MaplInfo software | Often usled i.n business and
for storing vector data. GIS applications.
SQLite/SpatiaLite .sql?te / | A spatial extension of SQLite | Used for compfact data
.sqlite3 database for vector data. storage and querying.
TIFF/GeoTIFF HE / tiff A wid.ely used form.at for raster Fommonly used for satellite
graphics and geospatial data. imagery, DEMs.
) ) Compressed image format with | Used for less precise raster
JPEG Jjpg / -jpeg . : ,
potential quality loss. data and web images.
PNG N Lossless image format supporting | Suitable for web and high-
Phg transparency. quality images.
ASCII Grid s Text-based format representing psed for simple raster d.ata
raster data as ASCII values. interchange and processing.
Rast Fi ERDAS 1 i fi t i
aster ERDAS Imagine img ormat used by S Imagine | Used or. remote sensing
software for raster data. and satellite data.
Grid (Various) grd A generic format for grid-based Used. .in various  GIS
raster data. applications.
A file format and data model that Used for large datasets and
HDF5 .h5 / .hdf5 supports the creation and access o 8
e scientific research.
of scientific data.
NetCDF ne A. fo.rTnat for array-oriented Us.ed .fc.)r climat.e data and
scientific data. scientific modeling.
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These formats are commonly used in QGIS for various types of geospatial data. Each format
has its own strengths and is chosen based on the requirements of the project, such as data
precision, compatibility, and storage needs.

To add and create vector and raster layers in QGIS, follow these steps:
1. Adding Vector Layers (Polygon and Points)
a. Adding an Existing Vector Layer

1. Open QGIS.
Go to the "Layers” panel or use the "Browser" panel.
Click on the "Add Layer" icon (or press Ctrl+Shift+V).
Select "Add Vector Layer" from the dropdown menu.

AR

In the "Data Source Manager" window, click "Browse" to navigate to your file.
o For Shapefiles (.shp), select the file with the extension .shp.
o For other vector formats (e.g., GeoJSON, KML), select the appropriate file.
6. Click "Open," and then click "Add" to load the vector layer into QGIS.
b. Creating a New Vector Layer
1. Go to "Layer” in the top menu.
2. Select "Create Layer" and then choose "New Shapefile Layer..." or "New Geopackage
Layer...".
In the dialog box, choose the Geometry Type (Point, Line, or Polygon).
Set the CRS (Coordinate Reference System) if different from the default.
Add fields (attributes) by specifying the field name and data type.
Click "OK" to create the new layer.
7. The new layer will appear in the "Layers" panel.

o Uk W

2. Adding Raster Layers (Including Shapefiles as Raster)
a. Adding an Existing Raster Layer
1. Click on the "Add Layer" icon or go to "Layer > Add Layer".
2. Choose "Add Raster Layer” (or press Ctrl+Shift+R).
3. Inthe "Data Source Manager" window, click "Browse" to navigate to your raster file.
o Common raster formats include .tiff, .jpeg, .png.
4. Select the raster file and click "Open" and then "Add".
b. Converting a Shapefile to a Raster Layer
1. Go to the "Raster” menu in QGIS.
Select "Conversion > Rasterize (Vector to Raster)".
In the dialog box, select the input vector layer.
Set the output raster file location and name.

g1 W

Define additional parameters such as the pixel size.
6. Click "Run" to create the raster layer.

3. Editing and Managing Layers

a. Editing Vector Layers
1. Right-click on the vector layer in the "Layers" panel.
2. Select "Toggle Editing" to enable editing mode.

13
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3. Use the "Add Feature" tool (point, line, or polygon) to add new geometries.
4. Click on the map to place the geometry and fill in attribute information in the pop-
up dialog box.
5. When done, click "Toggle Editing" again and choose "Save Edits".
b. Managing Layer Properties
1. Right-click the layer in the "Layers" panel and select "Properties".
2. Adjust settings such as symbology, labels, or metadata as needed.
3. Click "OK" to apply changes.
4. Saving and Exporting Layers
e Vector Layers:
o Right-click the vector layer and select "Export > Save Features As..." to save the
layer in various formats (Shapefile, Geo]JSON, etc.).
o Raster Layers:
o Right-click the raster layer and select "Export > Save As..." to export the raster
in different formats (GeoTIFF, JPEG, etc.).
5. Creating Points on an Imported Raster (Shapefile)
1. Load the raster or shapefile into QGIS.
2. Create a new point vector layer by following the steps in Creating a New Vector
Layer.
3. Toggle Editing on the new point layer and use the "Add Point" tool to mark points on
the raster or shapefile.
4. Save your edits when done.
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Fig. 1. Example of vector data (shape file in QGIS)
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Fig. 2. Example of raster data (tif. File in QGIS)
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Fig. 3. Added vector layer of the raster layer
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Fig. 4. Added various layers to show the lakes, airports, etc. with the help of polygons and

points.

Assignment for students

1. In QGIS, create the new project and add some features of raster and vector data

on it. Also write the procedure done for this.
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2. Write the differences between vector and raster data.
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Exercise No. 4
Introduction to Image Processing Software

Objective: To introduce students to various Image Processing Software

Image processing software is essential in various fields, including agriculture, where it plays a crucial
role in analyzing and interpreting satellite and aerial images. These software tools allow users to
manipulate, analyze, and enhance images to extract meaningful information for decision-making.
This section introduces the fundamentals of image processing software, particularly in the context
of precision farming and agricultural applications.

What is Image Processing?

Image processing involves a series of techniques used to improve the quality of an image or to
extract useful information from it. The process can include operations like filtering, enhancing,
segmenting, and classifying images to derive insights that are not immediately visible to the naked

eye.

Importance in Agriculture

In agriculture, image processing software is used to:
Monitor Crop Health: By analyzing multispectral or hyperspectral images, farmers can
detect crop stress, disease, and nutrient deficiencies.
Soil Analysis: Image processing can help in mapping soil properties such as moisture,
organic matter content, and texture.
Yield Prediction: Processed images can be used to estimate crop yield by analyzing
vegetation indices like NDVI (Normalized Difference Vegetation Index).
Precision Farming: Image data helps in making informed decisions about irrigation,
fertilization, and pest control by providing spatially accurate information.

Common Image Processing Software

1. ERDAS IMAGINE:
Details: A comprehensive remote sensing application for geospatial data authoring,
this software is widely used for image processing and spatial data analysis.
Platform Used: Windows.
Use in Agriculture: Crop monitoring, soil analysis, land use and land cover mapping.
Access: Paid.

2. ENVI (Environment for Visualizing Images):
Details: ENVI specializes in processing geospatial imagery and is known for its
advanced spectral analysis tools.
Platform Used: Windows, macOS.
Use in Agriculture: Analyzing multispectral and hyperspectral data, vegetation
health monitoring, precision agriculture.
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Access: Paid.
3. QGIS with Orfeo Toolbox (OTB):
Details: QGIS is an open-source GIS software that can be enhanced with Orfeo
Toolbox for advanced remote sensing applications.
Platform Used: Windows, macOS, Linux.
Use in Agriculture: Image classification, vegetation index calculation, change
detection.
Access: Open access.
4. Google Earth Engine:
Details: A cloud-based platform for planetary-scale environmental data analysis,
Google Earth Engine is widely used for processing satellite imagery.
Platform Used: Web-based.
Use in Agriculture: Large-scale crop monitoring, deforestation mapping, disaster
management.
Access: Open access (with a free tier, some features may be limited).
5. SNAP (Sentinel Application Platform):
Details: Developed by ESA, SNAP is tailored for processing Sentinel satellite data but
supports other sensors as well.
Platform Used: Windows, macQOS, Linux.
Use in Agriculture: Monitoring crop growth, assessing flood impact on agriculture,
soil moisture estimation.
Access: Open access.
Basic Workflow of Image Processing
1. Image Acquisition:
Obtain images from satellite platforms (e.g., Landsat, Sentinel) or drones.
Ensure images are in a compatible format (e.g., GeoTIFF).
2. Preprocessing:
Radiometric Correction: Adjust the image data to correct sensor errors.
Geometric Correction: Align the image to a map projection.
Atmospheric Correction: Remove the effects of the atmosphere on the image data.
3. Image Enhancement:
Contrast Stretching: Improve the visibility of features in the image.
o Filtering: Apply spatial filters to reduce noise or highlight specific features.
4. Image Classification:
Unsupervised Classification: Group pixels into clusters without prior knowledge.
Supervised Classification: Use training data to categorize pixels into known classes
(e.g., crop types).
5. Post-Processing:
Accuracy Assessment: Evaluate the classification accuracy using ground truth data.
Map Creation: Convert the processed image into thematic maps for decision-

making.
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Applications in Precision Farming

Variable Rate Technology (VRT): By analyzing processed images, farmers can apply inputs
like fertilizers and pesticides variably across the field, optimizing resource use.

Crop Monitoring: Image processing helps in tracking crop growth stages, identifying
stressed areas, and predicting yield.

Land Use Mapping: Processed images can differentiate between different land uses, helping
in the efficient management of agricultural landscapes.

Image processing in QGIS
Basic image processing in QGIS involves several steps, from loading the raster image to

performing simple operations like contrast adjustment, filtering, and raster calculations.

Below are the steps for simple image processing in QGIS:
1. Loading a Raster Image

1.
2.

4,

Open QGIS.

Click on the "Add Layer" icon or go to "Layer > Add Layer > Add Raster Layer..." (or
press Ctrl+Shift+R).

In the "Data Source Manager"” window, click "Browse" to navigate to your raster file
(e.g. .tiff, .jpeg, .png).

Select the raster file and click "Open" and then "Add" to load the image into QGIS.

2. Adjusting Image Brightness and Contrast

1.
2.
3.
4

5.
6.

Right-click on the loaded raster layer in the "Layers" panel.

Select "Properties” to open the "Layer Properties" window.

Go to the "Symbology" tab.

Under the "Contrast Enhancement” section, select an option like "Stretch to
MinMax", "Cumulative count cut”, or "No enhancement”.

Adjust the Min and Max values manually if necessary.

Click "Apply" to see the changes on the map and "OK" to close the properties window.

3. Resampling or Reprojecting the Image

1.
2.
3.

4.
5.

Go to the "Raster” menu at the top.

Select "Projections > Warp (Reproject)”.

Choose the input raster layer and specify the output coordinate reference system
(CRS).

Set the output file location and click "Run".

The reprojected raster will be added to the map.

4. Applying Simple Raster Filters

1.
2.

3.
4.

Go to the "Raster” menu and select "Raster Calculator...".
Use the "Raster Calculator” window to apply basic mathematical operations (e.g.,
band math) on your raster.
o Example: ("band1@1" + "band2@1") / 2 for averaging two bands.
Set the output file path and name.
Click "OK" to process and create the new raster layer.

Alternatively, for predefined filters:
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1. Go to "Raster" > "Analysis".
2. Choose filters like "Sieve,"” "Fill nodata," or "Clip".
3. Setthe parameters and run the filter.
5. Clipping the Raster to a Specific Area
1. Go to the "Raster” menu and select "Extraction > Clip Raster by Extent".
2. In the "Clip Raster by Extent" window, select the raster layer.
3. Set the extent by choosing from the map canvas, manually entering coordinates, or
using an existing vector layer.
4. Set the output file location and click "Run".
6. Reclassifying Raster Values
1. Go to "Raster” > "Raster Calculator...".
2. Use expressions to reclassify values, such as:
o ("raster@1" <=50) * 1 + ("raster@1" > 50) * 2 to reclassify values below and
above 50.
3. Set the output file location and name.
4. Click "OK" to create the reclassified raster.
7. Creating a Hillshade or Slope Map
1. Go to the "Raster” menu and select "Terrain Analysis" > "Hillshade" or "Slope".
2. Choose the input DEM (Digital Elevation Model) raster layer.
3. Set the azimuth, altitude, and Z-factor for hillshade (if applicable).
4. Specify the output file location and name.
5. Click "Run" to generate the hillshade or slope map.
8. Exporting the Processed Image
1. Right-click on the processed raster layer in the "Layers" panel.
2. Select "Export” > "Save As...".
3. Choose the desired format (e.g., GeoTIFF, JPEG).
4. Set the outputlocation and file name.
5. Adjust any additional parameters, such as the CRS or resolution, and click "OK".
9. Saving the Project
1. Go to "Project” in the top menu.
2. Select "Save" or "Save As" to save the QGIS project, preserving all layers and settings.

Assignment for students
1. List out various image processing software.
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2. Prepare the flow diagram of image processing in QGIS.
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Exercise No. 5

Generation of spectral profiles of different objects

Objective: To introduce students about concept of spectral profiles and steps for generation
of spectral profiles of different objects in QGIS

Spectral profiles refer to the distinct patterns of reflectance or radiance that different objects
or materials exhibit across various wavelengths of the electromagnetic spectrum. These
profiles are unique for different objects like vegetation, water, soil, and urban areas and are
crucial in remote sensing and image classification. By analyzing the spectral profile, we can
identify and differentiate between various land cover types or materials based on their
spectral characteristics.

The generation of spectral profiles of different objects is a powerful tool in precision farming,

offering various applications that enhance agricultural management practices. Its application

are as given below:

1. Crop Health Monitoring
Early Detection of Stress: Spectral profiles allow for the early detection of plant stress
caused by factors like nutrient deficiencies, water stress, or pest infestations. By
comparing the spectral profile of healthy plants with stressed plants, farmers can
identify and address issues before they significantly impact crop yields.
NDVI and Vegetation Indices: Using spectral profiles, indices like the Normalized
Difference Vegetation Index (NDVI) can be calculated. These indices provide a
quantitative measure of plant health and vigor, helping farmers make informed
decisions about irrigation, fertilization, and other management practices.

2. Precision Irrigation Management
Water Stress Detection: Spectral profiles can indicate the water status of crops by
analyzing specific wavelengths related to water absorption. This information helps in
optimizing irrigation schedules, ensuring crops receive the right amount of water at the
right time, thereby conserving water resources and reducing costs.
Soil Moisture Estimation: In combination with other data, spectral profiles can help
estimate soil moisture levels, allowing farmers to target irrigation more precisely to
areas that need it.

3. Nutrient Management
Variable Rate Application (VRA): Spectral profiles can reveal variations in nutrient
levels within a field. By identifying areas with nutrient deficiencies or surpluses,
farmers can apply fertilizers variably across the field, improving nutrient use efficiency
and reducing environmental impact.
Identifying Specific Nutrient Deficiencies: Different nutrient deficiencies can cause
specific changes in plant reflectance. For example, nitrogen deficiency often causes
changes in the red and near-infrared bands, which can be detected through spectral
profiles.
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4. Weed and Pest Management
Weed Detection: Spectral profiles can differentiate between crops and weeds, even
when they are visually similar. This differentiation helps in targeted herbicide
application, reducing chemical use and minimizing damage to crops.
Pest Infestation Monitoring: Spectral changes caused by pest infestations can be
detected early, allowing for timely interventions and reducing the need for widespread
pesticide applications.

5. Crop Yield Estimation and Mapping
Yield Prediction: By analyzing the spectral profiles of crops throughout the growing
season, farmers can estimate potential yields with higher accuracy. This helps in
planning harvest operations and market strategies.
Zoning for Management Practices: Spectral profiles enable the creation of
management zones within a field based on crop performance. These zones allow for
tailored management practices, leading to more uniform crop growth and optimizing
yield across the field.

6. Soil Mapping and Analysis
Soil Property Estimation: Spectral profiles can be used to estimate soil properties
such as organic matter content, soil texture, and mineral composition. This information
is valuable for precision soil management, helping farmers decide on soil amendments,
tillage practices, and crop selection.
Erosion and Degradation Monitoring: By analyzing the spectral profiles of soil,
farmers can monitor erosion or degradation patterns, allowing for timely soil
conservation measures.

7. Crop Classification and Land Use Planning
Accurate Crop Identification: Spectral profiles can be used to classify different crops
within a field or across a landscape. This classification is useful for crop rotation
planning, land use management, and ensuring compliance with agricultural policies or
certification requirements.
Optimizing Crop Layout: Spectral analysis can help determine the best locations for
different crops based on their spectral responses, leading to optimized land use and
better overall productivity.

8. Post-Harvest Analysis
Quality Assessment: Spectral profiles can be used to assess the quality of harvested
crops, such as determining the ripeness of fruits or the moisture content of grains. This
helps in sorting and grading produce, improving market value.
Storage Management: Monitoring spectral profiles during storage can help detect
spoilage or degradation, enabling better storage management and reducing post-
harvest losses.
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Steps for Generating Spectral Profiles of Different Objects in QGIS

To generate spectral profiles of different objects using QGIS, follow these steps:
1. Install the Required Plugins

1.
2.
3.

4.
5.

Open QGIS and go to the "Plugins” menu.

Select "Manage and Install Plugins...".

In the Plugin Manager window, search for "Semi-Automatic Classification Plugin
(SCP)".

Install the SCP plugin by clicking on the "Install Plugin” button.

After installation, the SCP toolbar will appear in QGIS.

2. Load a Multispectral Raster Image

1.
2.

4.

Go to the "Layers" panel or use the "Browser" panel.

Click on the "Add Raster Layer" icon or go to "Layer > Add Layer > Add Raster
Layer...".

Browse and select the multispectral raster file (e.g., a satellite image like Landsat,
Sentinel).

Click "Open" and then "Add" to load the raster into QGIS.

3. Define the Region of Interest (ROI)

1.
2. Click on "ROI Creation” in the SCP toolbar.

3.

4. Choose the "Create ROI by Layer” option to draw polygons over the objects (e.g.,

o

Open the SCP toolbar by clicking on the "SCP" icon in the toolbar.
In the ROI Creation window, select the bands you want to analyze.

vegetation, water, soil) whose spectral profiles you want to generate.
Alternatively, use the "Create ROI by Points" tool to mark specific points for the
objects.
Click on the map to draw polygons or points over the objects of interest.
Assign a class name and ID for each ROI (e.g., vegetation, water) in the ROI creation
panel.

4. Generate Spectral Profiles

1.

AR

After creating the ROIs, click on "Spectral Signature Plot" in the SCP toolbar.

In the Spectral Signature Plot window, select the ROIs you created.

Choose the bands you want to analyze for the spectral profile.

Click "Plot" to generate the spectral profiles of the selected ROIs.

The spectral profile graph will display, showing the reflectance values across different
bands for each object.

5. Analyzing the Spectral Profiles

1.
2.

Review the spectral profiles plotted on the graph.
Compare the profiles of different objects to understand how they vary across different
wavelengths.
For example, vegetation typically shows high reflectance in the near-infrared
(NIR) band, while water bodies have low reflectance across all bands.
You can export the spectral profiles by clicking on the export button in the Spectral
Signature Plot window if you want to save them for further analysis.
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6. Save the ROIs and Spectral Data
1. Go to the "ROI Creation" window in the SCP toolbar.
2. Click on "Save ROIs" to save the polygons or points you created as a vector layer.
3. Save the spectral data by clicking on "Save Signatures” in the SCP toolbar.
7. Optional: Use Spectral Profiles for Classification
1. In the SCP toolbar, you can use the "Classification" tool to classify the entire raster
based on the spectral profiles you generated.
2. Select the classification method (e.g., Maximum Likelihood, Minimum Distance) and
the spectral signatures to apply.
3. Run the classification to produce a land cover map based on the spectral profiles.
8. Save the Project
1. Go to "Project” in the top menu.
2. Select "Save" or "Save As" to save your QGIS project, including all layers, ROIs, and
spectral profiles.

Assignment for students
1. Describe in short about the applications of spectral profiles in precision farming.
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2. Prepare the flow diagram for generation of spectral profiles of different objects
in QGIS.
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Exercise No. 6

Multispectral Remote Sensing for Soil Mapping

Objective: To introduce students about concept of Multispectral Remote Sensing and its use
for soil mapping with the help of satellite images and QGIS

Multispectral remote sensing involves the collection of image data across multiple spectral
bands of the electromagnetic spectrum. These bands typically include both visible light (red,
green, blue) and non-visible wavelengths such as near-infrared (NIR) and shortwave infrared
(SWIR). The number of bands and their specific wavelengths can vary depending on the sensor
or satellite used.
Typical Bands and Wavelengths in Multispectral Remote Sensing
Visible Light Bands:
Blue Band:
Wavelength: Approximately 450-495 nm
Purpose: Penetrates water bodies, useful in studying aquatic features and
vegetation.
Green Band:
Wavelength: Approximately 495-570 nm
Purpose: Useful for assessing plant health and detecting chlorophyll.
Red Band:
Wavelength: Approximately 620-750 nm
Purpose: Strongly absorbed by chlorophyll, making it important for
vegetation analysis.
Non-Visible Bands
Near-Infrared (NIR) Band:
Wavelength: Approximately 750-900 nm
Purpose: Reflects strongly from healthy vegetation and is used for
monitoring plant biomass and health.
Shortwave Infrared (SWIR) Bands:
Wavelength: Ranges from approximately 1,100-2,500 nm
Purpose: Sensitive to moisture content in soil and vegetation, useful for
detecting water stress, soil moisture, and mapping soil properties.
Number of Bands
The number of bands in a multispectral sensor can range from as few as three (such as in a
basic RGB camera) to over a dozen in more advanced systems. For example:
Landsat 8 (Operational Land Imager - OLI):
Number of Bands: 11
Wavelength Range:
» Coastal/Aerosol: 433-453 nm
* Blue: 450-515 nm
*= Green: 525-600 nm
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Red: 630-680 nm
NIR: 845-885 nm
SWIR 1:1,560-1,660 nm
SWIR 2:2,100-2,300 nm
Panchromatic: 500-680 nm (used for higher-resolution grayscale
images)
Cirrus: 1,360-1,390 nm (for detecting clouds)
Thermal Infrared (TIRS) Bands 1 & 2: 10,600-11,190 nm and 11,500-
12,510 nm (used for temperature mapping)
Sentinel-2 (Multispectral Instrument - MSI):
Number of Bands: 13
Wavelength Range:

Blue: 490 nm
Green: 560 nm
Red: 665 nm
NIR: 842 nm
Red Edge: 705 nm, 740 nm, 783 nm (used for vegetation monitoring)
SWIR: 1,610 nm, 2,190 nm

Each of these bands captures specific information about the Earth's surface, allowing for

detailed analysis of various natural and man-made features.

Applications in Soil Mapping

In the context of soil mapping, these multispectral bands help in identifying and analyzing soil
properties by examining how different soil types and conditions reflect light across these
bands. For instance, the NIR band is particularly useful in distinguishing between bare soil and
vegetated areas, while SWIR bands can be used to assess soil moisture and mineral
composition. By analyzing the spectral signatures of different soil types, multispectral remote
sensing can provide critical information for precision agriculture, land management, and
environmental monitoring.

Steps to Conduct Soil Mapping Using Multispectral Remote Sensing in QGIS

1. Install and Set Up QGIS
Install QGIS: If you haven't already, download and install the latest version of QGIS
from the official website.
Install Plugins: Ensure that the Semi-Automatic Classification Plugin (SCP) is
installed as it will be essential for handling and processing multispectral data.

2. Acquire Multispectral Data
Satellite Data Sources: Obtain multispectral imagery from sources like Landsat,
Sentinel-2, or commercial providers. These datasets usually contain multiple bands,
including visible and infrared wavelengths.
Data Download: Download the required images in GeoTIFF format or other supported
formats.
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3. Load Multispectral Data into QGIS
1. Open QGIS and go to "Layers" > "Add Layer” > "Add Raster Layer...".
2. Browse and select the multispectral images you downloaded.
3. Click "Open" to load the raster layers into QGIS. Each band will appear as a separate
layer in the Layers panel.
4. Preprocess the Data
Band Combination: If needed, combine the bands into a single composite image using
the "Build Virtual Raster (Catalog)" tool found under "Raster” > "Miscellaneous".
This helps in analyzing the combined spectral information.
Atmospheric Correction: Perform atmospheric correction if required, using tools like
SCP's Atmospheric Correction feature. This step corrects the influence of the
atmosphere on the spectral reflectance values.
5. Define Regions of Interest (ROIs)
1. Identify Soil Types: Define regions representing different soil types or conditions in
your area of interest (e.g., sandy soil, clay soil, organic-rich soil).
2. Use the SCP toolbar: In the ROI Creation tool, draw polygons over the areas
representing each soil type.
3. Label ROIs: Assign appropriate labels (e.g., Soil Type 1, Soil Type 2) to each polygon.
6. Generate Spectral Profiles of Soil Types
1. Use the Spectral Signature Plot tool in SCP to generate and analyze the spectral
profiles of the defined ROlIs.
2. This step helps understand how different soil types reflect light across various bands,
providing a basis for classification.
7. Classify the Soil Types
1. Supervised Classification: Use the spectral profiles to classify the entire raster image
into different soil types using the Supervised Classification tool in SCP.
o Selecta classification algorithm (e.g., Maximum Likelihood, Minimum Distance).
o Run the classification to produce a soil map with distinct classes for each soil
type.
2. Unsupervised Classification: Alternatively, you can use an unsupervised classification
approach if the soil types are not well-defined in advance.
8. Post-Classification Processing
1. Accuracy Assessment: Validate the classification results using ground-truth data or
accuracy assessment tools in SCP.
2. Refinement: Refine the classification if necessary by adjusting ROIs, re-running the
classification, or applying post-classification filtering.
9. Export and Visualize the Soil Map
1. Styling: Apply suitable symbology to the classified raster to visually distinguish
between different soil types.
2. Exportthe Map: Export the soil map as a GeoTIFF, JPEG, or PDF for further analysis or
sharing.
10. Interpret and Apply the Results
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Soil Property Analysis: Use the classified soil map to interpret soil properties such as
fertility, moisture content, or erosion risk.
Agricultural Planning: Integrate the soil map into precision agriculture practices, such
as variable rate application of fertilizers or selecting appropriate crops for different soil
Zones.
Benefits of Using Multispectral Remote Sensing for Soil Mapping
Large Area Coverage: Multispectral remote sensing enables the mapping of large and
inaccessible areas efficiently.
Non-Destructive: Soil mapping is done remotely without physically disturbing the soil.
Time-Efficient: It provides timely data, enabling rapid assessment and decision-
making.
Cost-Effective: Reduces the need for extensive ground sampling, lowering overall costs.
Challenges
Data Complexity: Requires expertise in remote sensing and GIS to process and
interpret data correctly.
Atmospheric and Seasonal Effects: Variability in atmospheric conditions or seasonal
changes can affect the accuracy of the analysis.

Assignment for students

1. Describe in short about the applications of Multispectral Remote Sensing in
precision farming.
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2. Prepare the flow diagram for Multispectral Remote Sensing for Soil Mapping with
the help of QGIS.
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Exercise No. 7
Fertilizer Recommendations Based on VRT

Objective: To introduce students about concept of Variable Rate Technology and learn about
Fertilizer Recommendations Based on it

Concept of VRT (Variable Rate Technology)

Variable Rate Technology (VRT) refers to the practice of applying inputs such as fertilizers,
seeds, pesticides, and water at variable rates across a field based on specific conditions and
needs. VRT is a key component of precision agriculture, enabling farmers to optimize the use
of inputs, enhance crop yields, and minimize environmental impacts.

How VRT Works

VRT uses data from various sources, such as soil tests, crop sensors, satellite imagery, and GPS,
to create detailed maps of field variability. These maps inform the precise application of inputs,
ensuring that each area of the field receives the right amount of fertilizer, water, or other
inputs.

VRT systems can operate in two main ways:

1. Map-Based VRT: Pre-determined application maps are created based on field data
collected through soil sampling, yield monitors, or remote sensing. These maps are
uploaded to the VRT equipment, which adjusts the application rates as the machinery
moves through the field.

2. Sensor-Based VRT: Sensors mounted on equipment measure real-time conditions,
such as soil moisture or crop health, and adjust the application rates on-the-go without
relying on pre-made maps.

Fertilizer Recommendations Based on VRT

1. Data Collection and Analysis
Soil Sampling and Testing: Collect soil samples from different zones of the field to
analyze nutrient levels, pH, organic matter, and other soil properties.
Remote Sensing and Mapping: Use satellite imagery, drones, or multispectral sensors
to assess variability in crop health, biomass, and soil properties across the field.
Yield Monitoring: Analyze historical yield data to identify patterns of variability in
productivity within the field.

2.Zone Delineation
Field Zoning: Based on the collected data, divide the field into management zones that
represent areas with similar soil properties, crop conditions, and nutrient needs.
Creation of Prescription Maps: Develop prescription maps that specify the amount of
fertilizer required for each zone. These maps are created using Geographic Information
Systems (GIS) and often take into account factors such as soil type, previous crop
performance, and nutrient status.

3. Fertilizer Application Using VRT
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Equipment Calibration: Upload the prescription map to VRT-enabled fertilizer
spreaders or applicators. Ensure that the equipment is calibrated correctly to apply the
recommended rates accurately.
Variable Rate Application: As the equipment moves across the field, it automatically
adjusts the application rate based on the prescription map, applying more fertilizer in
zones that require it and less in areas with sufficient nutrient levels.

4. Monitoring and Adjustment
Real-Time Monitoring: Use on-the-go sensors or yield monitors to track the
effectiveness of fertilizer application and adjust the prescription maps for future use.
Post-Application Analysis: Analyze the crop response and yield data after fertilization
to refine the VRT strategy. This feedback loop helps in improving the accuracy and
efficiency of fertilizer recommendations over time.

Advantages of VRT in Fertilizer Application
Increased Efficiency: Optimizes the use of fertilizers by applying the right amount
where needed, reducing waste.
Cost Savings: Reduces input costs by avoiding over-application and ensuring that
fertilizer is only used where it's beneficial.
Environmental Benefits: Minimizes nutrient runoff and leaching, reducing the risk of
water pollution and other environmental issues.
Enhanced Crop Yields: Provides tailored nutrient management that can lead to
improved crop health and higher yields.

Challenges
Initial Cost: The technology and equipment required for VRT can be expensive.
Data Management: Requires significant data collection, processing, and
interpretation, which can be complex and time-consuming.
Training and Expertise: Farmers need training to effectively use VRT systems and
interpret the data.

Assignment for students
1. Describe in short about the applications of VRT in precision farming.
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2. Prepare the diagram for thematic representation of VRT.
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Exercise No. 8
Fertilizer Estimations Based on STCR

Objective: To introduce students about concept of STCR and learn about Fertilizer estimations
Based on it

What is STCR

The Soil Test Crop Response (STCR) approach represents a key strategy for balanced
fertilization. It is based on the concept of targeted yield, which ensures that fertilizers are
applied in precise amounts according to soil test results. This approach is designed to
maximize resource utilization and enhance nutrient management. Fertilizer application
guided by soil tests is an effective tool for determining the exact nutrient requirements of crops
and optimizing their growth.

The development of the STCR approach began with Troug's concept of fertilizer
prescription equations in 1960. This idea was further refined by Ramamoorthy in 1967, who
established the theoretical foundation and experimental methods suitable for Indian
agricultural conditions. Ramamoorthy’s work demonstrated a linear relationship between
crop yield and nutrient uptake, allowing for the estimation of fertilizer requirements based on
soil and nutrient efficiency. This concept led to the initiation of the All India Coordinated
Research Project (AICRP) on Soil Test Crop Response (STCR) by the Indian Council of
Agricultural Research (ICAR) in 1967-68. Under the guidance of Dr. B. Ramamurthy and his
team at the Indian Agricultural Research Institute (IARI), New Delhi, the project aimed to
develop soil test-based fertilizer recommendations. Initially involving eight centers, the
project expanded to include five more centers by 1970-71.

The STCR approach is distinct from other methods as it not only provides
recommendations based on soil test results but also indicates achievable yield levels with
appropriate management practices. This approach integrates scientific principles to ensure
that the application of fertilizers, whether from external sources or organic amendments, is
balanced with the nutrients available in the soil. It provides a comprehensive framework for
managing fertilizers efficiently, reducing waste, and enhancing overall crop performance.

Methodology
The basic data required for formulating fertilizer recommendations for targeted yield
includes:
1. Nutrient Requirement (NR): Calculated as the total nutrient uptake divided by the
grain yield.
2. Percentage Contribution from Soil Available Nutrients (CS): Determined by
dividing the total nutrient uptake in control plots by the soil test value of the nutrient
in those plots and multiplying by 100.
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3. Percentage Contribution from Applied Fertilizer Nutrients (CF): Calculated using
the difference between nutrient uptake in treated plots and soil test values in those
plots, divided by the amount of nutrient added as fertilizer, then multiplied by 100.
4. Percentage Contribution from Organic Sources (CFYM): Calculated similarly to CF
but considering nutrient uptake from plots treated with farmyard manure (FYM).
The parameters are calculated as follows:

1. Nutrient requirement (NR):

Total uptake of nutrient
NR = —
Grain yield
2. Per cent contribution from soil available nutrients (CS):

_ Total nutrient uptake in control plots (kg / ha)
~ Soil test value of nutrient in control plots (kg / ha)

x100

3. Per cent contribution from added fertilizers (CF):

(Total uptake of nutrients in treated plots) — (STV of nutrient in treated plots xlcTSO)
CF == x100
Amount of nutrient added as fertilizer (kg / ha)

4. Per cent contribution from organic sources (CFYM):

(Total uptake of nutrients in FYM treated plots) — (STV of nutrient in FYM treated plots x CS/100 9

100
Amount of nutreint added as FYM (kg / ha)

CFYM =

In STCR experimentation, there are two main approaches: deductive and inductive.
Deductive Approach: This method involves selecting different sites to represent
various levels of soil fertility, and the results are generalized.

Inductive Approach: This method involves creating variations in soil fertility within a
single field experiment to reduce differences in soil type, management practices, and
climatic conditions.

STCR experimentation is conducted in three phases:

1. Development of Fertility Gradient: A representative field is divided into strips with
increasing levels of fertilizers (N, P, and K) to create a gradient from low to high fertility.
An exhaust crop is grown to facilitate nutrient transformations in the soil.

2. Test Crop Growth: After harvesting the exhaust crop, the field is divided into subplots,
and selected treatments (N, P, K, and FYM) are applied. The test crop is grown to
maturity, and soil samples are collected and analyzed for available nutrients. Grain and
straw yields and total nutrient uptake are measured. Fertilizer requirement equations
for nitrogen (FN), phosphorus (FP), and potassium (FK) are calculated.
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Fertilizer Requirement Equations for Chemical Fertilizers:
FN= (NR/CF) x100 T - (CS/CF) x SN

FP= (NR/CF) x100 T - (CS/CF) x SP

FK= (NR/CF) x100 T — (CS/CF) xSK

Fertilizer Requirement Equations for Conjoint Use of Chemical Fertilizer and FYM:

FN = (NR/CF*) x100 T — (CS/CF*) x SN — (CFYM/CF*) x M
FP = (NR/CF*) x 100 T — (CS/CF*) x SP — (CFYM/CF*) x M
FK= (NR/CF*) x 100 T — (CS/CF*) x SK — (CFYM/CF*) x M

Where,

FN = Fertilizer nitrogen (kg N ha™)

FP = Fertilizer phosphorus (kg P ha™)

FK = Fertilizer potassium (kg K ha™)

NR = Nutrient requirement of nitrogen, phosphorus and potassium
CF = Percent contribution of concerned nutrient from fertilizer
CF* = Percent contribution of concerned nutrient from FYM.
CS = Percent contribution of concerned nutrient from soil
CFYM = Percent contribution of concerned nutrient from FYM

T = Targeted yield (q ha™)

SN = Soil test value for available nitrogen (kg ha™)

SP = Soil test value for available phosphorus (kg ha™)

SK = Soil test value for available potassium (kg ha™)

M = Concerned nutrient content in organic matter

After determining the fertilizer requirements, statistical analysis is performed, and a target
yield equation is developed using multiple regression.
3. Verification or Follow-Up Trials: The target yield equation developed is then verified
at different locations to confirm its validity.

There is a significant difference between "Fertilizing the soil" and "Fertilizing the crop.” Soil
test crop response-based fertilizer recommendations maintain the real balance between
applied fertilizer nutrients and soil-available nutrients. STCR studies have been undertaken in
various parts of India for different crops like wheat, rice, and pearl millet. Applying plant
nutrients based on soil tests helps in achieving a higher response ratio because nutrients are
applied considering the specific deficiencies of those nutrients. This approach corrects
nutrient imbalances in the soil and harnesses the synergistic effects of balanced fertilization.
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Example:
Consider the following information for paddy cultivation:
The target yield for paddy is 50 quintals per hectare.
Based on research, the nutrient uptake for paddy is as follows:
Nitrogen (N): 1.1 kg per quintal
Phosphorus (P): 0.6 kg per quintal
Potassium (K): 0.9 kg per quintal
Calculate the total nutrient requirement per hectare for each of N, P and K

1. Calculate the Total Nutrient Requirement for Nitrogen (N):
Given Data:
NR (N) = 1.1 kg per quintal
Target Yield = 50 quintals per hectare
Calculation:

Total N Requirement = NR (N) x Target Yield
Total N Requirement = 1.1 kg/q x 50 q/ha
Total N Requirement = 55 kg/ha

2. Calculate the Total Nutrient Requirement for Phosphorus (P):
Given Data:
NR (P) = 0.6 kg per quintal
Target Yield = 50 quintals per hectare
Calculation:

Total P Requirement = NR (P) x Target Yield
Total P Requirement = 0.6 kg/q x 50 q/ha
Total P Requirement = 30 kg/ha

3. Calculate the Total Nutrient Requirement for Potassium (K):
Given Data:
NR (K) = 0.9 kg per quintal
Target Yield = 50 quintals per hectare

Calculation:
Total K Requirement = NR (K) x Target Yield
Total K Requirement = 0.9 kg/q x 50 q/ha
Total K Requirement = 45 kg/ha
Results:

1. Total Nitrogen Requirement: 55 kg/ha
2. Total Phosphorus Requirement: 30 kg/ha
3. Total Potassium Requirement: 45 kg/ha
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Assignment for students
1. Calculate the total nutrient requirement per hectare for N, P and K for wheat cultivation,

with the help of following data:

The target yield of wheat is 40 quintals per hectare.

Nutrient uptake for wheat is given as:
Nitrogen (N): 1.2 kg per quintal
Phosphorus (P): 0.5 kg per quintal
Potassium (K): 0.8 kg per quintal
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Exercise No. 9

Crop Stress Monitoring Using Geospatial Technology

Objective: To introduce students about concept of Crop stress (biotic/abiotic) and their
monitoring using geospatial technology

Monitoring crop stress using geospatial technology involves leveraging satellite imagery,
drones, and Geographic Information Systems (GIS) to detect and manage both biotic and
abiotic stress factors affecting crops. Here's a comprehensive overview of how geospatial
technology can be used for this purpose:

Types of Crop Stress
a. Biotic Stress
Biotic stress is caused by living organisms such as pests, diseases, and weeds. Common types
include:
Pests: Insects, nematodes, and other organisms that damage crops.
Diseases: Fungal, bacterial, and viral infections.
Weeds: Competing plants that affect crop growth and yield.
b. Abiotic Stress
Abiotic stress is caused by non-living factors such as environmental conditions. Common
types include:
Drought: Insufficient water availability.
Flooding: Excess water and waterlogging.
Temperature Extremes: High or low temperatures affecting crop health.
Nutrient Deficiency: Lack of essential nutrients in the soil.
Soil Salinity: High salt concentrations in the soil.

Geospatial Technologies for Crop Stress Monitoring
a. Satellite Imagery
1. Remote Sensing:
Types: Use of satellites equipped with sensors to capture images of the Earth's
surface in various wavelengths (e.g., visible, infrared).
Applications: Monitoring vegetation health, detecting stress symptoms, and
assessing field conditions.
2. Vegetation Indices:
Normalized Difference Vegetation Index (NDVI): Measures vegetation
health by comparing red and near-infrared light reflectance. Low NDVI values
can indicate stress.
Enhanced Vegetation Index (EVI): Provides improved sensitivity in high
biomass regions and is less affected by atmospheric conditions.
3. Time-Series Analysis:
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Analyze temporal changes in vegetation indices to identify stress patterns over
time.
b. Drones

1. High-Resolution Imaging:
Multispectral Cameras: Capture data across different spectral bands to assess
crop health and stress levels.
Hyperspectral Imaging: Provides detailed spectral information for detecting
specific stress factors.

2. Manual survey:
Field Surveys: Conduct detailed surveys to identify stress areas within fields.
Real-Time Monitoring: Capture real-time images to monitor crop conditions
and detect issues promptly.

3. Mapping and Analysis:
Generate high-resolution maps to visualize stress distribution and assess
severity.

c. Geographic Information Systems (GIS)

1. Data Integration:
Layering: Combine various data layers (e.g., soil types, weather patterns, crop
health) to analyze stress factors and their impact.
Spatial Analysis: Use GIS tools to identify patterns and correlations between
stress factors and crop performance.

2. Risk Assessment:
Vulnerability Mapping: Create maps to assess areas most at risk of stress
based on environmental conditions and crop types.
Predictive Modeling: Use GIS-based models to predict stress occurrences and
potential impacts.

3. Decision Support:
Action Plans: Develop targeted management strategies based on spatial
analysis results.
Resource Allocation: Optimize the allocation of resources (e.g., water,
fertilizers) to areas most affected by stress.

Implementation Steps
a. Data Collection
1. Satellite Data Acquisition:
Obtain satellite imagery from providers such as NASA, ESA, or commercial
satellite companies.
Choose appropriate imagery based on resolution and spectral bands needed
for stress detection.
2. Drone Deployment:
Plan drone flights to cover the field area and capture high-resolution images.
o Use calibrated sensors for accurate stress detection.
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3. Field Surveys:
Conduct on-ground surveys to validate remote sensing data and assess stress
symptoms.
b. Data Analysis
1. Image Processing:
Process satellite and drone images using software tools to calculate vegetation
indices and detect stress.
o Analyze image data to identify stress patterns and their causes.
2. GIS Analysis:
Import processed data into GIS software to create maps and conduct spatial
analysis.
o Overlay various data layers to understand the relationship between stress
factors and crop performance.
3. Interpretation:
Interpret results to identify areas of stress and determine the underlying
causes.
o Assess the severity and potential impact on crop yields.
c. Management and Action
1. Targeted Interventions:
Implement targeted management practices (e.g., pest control, irrigation
adjustments) based on stress analysis results.
Apply fertilizers or soil amendments in specific areas as needed.
2. Monitoring and Evaluation:
Continuously monitor crop health using geospatial technologies to track the
effectiveness of interventions.
Adjust management strategies based on ongoing observations and data.

Advantages
Early Detection: Identify stress factors before they cause significant damage,
allowing for timely interventions.
Precision Management: Apply resources more efficiently by targeting specific areas
of the field.
Improved Yields: Address stress factors effectively to enhance crop health and yield.
Challenges
Data Accuracy: Ensuring the accuracy of satellite and drone data for reliable stress
detection.
Technology Costs: The initial investment in geospatial technologies and data analysis
tools can be high.
Data Interpretation: Requires expertise to accurately interpret data and make
informed decisions.
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Assignment for students
1. With the help of flow diagram explain the process of crop stress monitoring using
geospatial technology
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Exercise No. 10

Study of Preparation of Nanoparticles in the Laboratory

Objective: To introduce students about general procedure for preparation of nanoparticles in
the laboratory for agricultural use

Nanoparticles are tiny particles with sizes ranging from 1 to 100 nanometers (nm). They
have unique properties due to their small size and high surface area, making them useful in
agriculture for tasks like enhancing nutrient delivery, improving soil quality, and controlling
pests. Preparing nanoparticles requires careful control of conditions to ensure they have the
right size, shape, and properties for their intended use.

Materials and Equipment

Materials:
Precursors: Substances from which nanoparticles are made, such as metal salts (e.g.,
silver nitrate) or organic compounds (e.g., polymers).
Stabilizers: Compounds added to prevent nanoparticles from clumping together (e.g.,
surfactants or polymers).
Solvents: Liquids used to dissolve the precursors (e.g., water, ethanol).
Reducing Agents (if applicable): Chemicals that help in reducing metal ions to form
nanoparticles (e.g., sodium borohydride).

Equipment:
Magnetic Stirrer: A device that mixes solutions by creating a rotating magnetic field.
Ultrasonic Bath or Probe Sonicator: Equipment that uses sound waves to mix and
break down particles.
High-Energy Ball Mill: A machine that grinds materials into nanoparticles using
heavy balls.
Furnace or Hydrothermal Reactor: Equipment used to heat materials to high
temperatures.
Centrifuge: A device that separates particles from liquids by spinning them at high
speeds.
Filter Apparatus: Used to separate solid particles from liquids.
Characterization Instruments: Devices used to analyze the size and structure of
nanoparticles (e.g., Transmission Electron Microscopy (TEM), Scanning Electron
Microscopy (SEM), X-ray Diffraction (XRD)).

Preparation Methods
a. Chemical Synthesis (Sol-Gel Method)
1. Preparation of Precursor Solution:
Dissolve metal salts (e.g., metal nitrates) in a solvent (e.g., water). This creates
a solution containing the metal ions needed to form nanoparticles.
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Add stabilizers to the solution to prevent the nanoparticles from sticking
together. Stabilizers can be polymers or surfactants that help keep the
nanoparticles dispersed.

2. Gel Formation:
Add a gelling agent (e.g., a polymer or organic reagent) to the solution while
stirring. This will cause the solution to turn into a gel.

o Maintain specific pH and temperature conditions to ensure proper gel

formation.

3. Drying and Calcination:
Dry the gel at a controlled temperature to remove any remaining solvents. This
process turns the gel into a dry, solid form known as a xerogel.
Place the xerogel in a furnace and heat it to high temperatures (e.g., 500-
1000°C). This step, called calcination, transforms the xerogel into
nanoparticles.

4. Characterization:
Use TEM, SEM, and XRD to examine the size, shape, and crystallinity of the
nanoparticles. TEM provides detailed images of the particles, SEM gives
surface images, and XRD identifies the crystal structure.

b. Physical Methods (Ball Milling)

1. Preparation:
Place metal powders or other materials in a high-energy ball mill. Add milling
balls and stabilizers to the chamber.
The milling balls collide with the metal powders, breaking them into smaller
particles.

2. Milling:
Operate the ball mill under controlled conditions (speed and time) to reduce
the particle size. Check the samples periodically to monitor the progress.

3. Characterization:
Analyze the nanoparticles using TEM, SEM, or XRD to confirm their size and
structure.

¢. Hydrothermal Synthesis

1. Preparation of Solution:
Dissolve metal salts or other precursors in a solvent (e.g., water). Add
stabilizers if needed to prevent particle agglomeration.

2. Hydrothermal Reaction:
Transfer the solution to a hydrothermal reactor, which is a sealed vessel that
can withstand high pressure and temperature.
Heat the solution to high temperatures (e.g., 150-250°C) under pressure. This
process helps to form nanoparticles.

3. Cooling and Collection:
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Allow the reactor to cool down after the reaction. Filter the solution to collect
the nanoparticles.
Wash the nanoparticles with distilled water to remove impurities and dry
them.

4. Characterization:
Use TEM, SEM, and XRD to determine the size, shape, and structure of
thenanoparticles.

Final Processing and Purification
1. Purification:
Use a centrifuge to separate nanoparticles from impurities or unreacted
materials. Centrifugation involves spinning the mixture at high speeds to force
particles to separate based on their density.
Re-suspend the nanoparticles in a suitable solvent and filter if necessary to
remove any remaining impurities.
2. Stabilization:
Add stabilizers or surfactants to keep the nanoparticles dispersed and prevent
them from clumping together.
3. Storage:
Store the nanoparticles in airtight containers, away from light and moisture, to
maintain their properties and effectiveness.
5. Quality Control
Characterization: Ensure nanoparticles have the desired size, shape, and properties
using analytical techniques like TEM, SEM, and XRD.
Testing: Evaluate the effectiveness and safety of nanoparticles in agricultural
applications to ensure they meet required standards.
6. Application
Incorporate the nanoparticles into agricultural products or systems as needed. Ensure
they are compatible and effective in enhancing agricultural practices.

Assignment for students
1. With the help of flow diagram explain the general process of Preparation of
Nanoparticles in the Laboratory.
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Exercise No. 11

Preparation of Nano Zinc Oxide (ZnO) Fertilizer

Objective: To synthesize zinc oxide nanoparticles for use as a nano fertilizer.

Materials Required:
Zinc acetate dihydrate (Zn(C,H30,),-2H,0)
Sodium hydroxide (NaOH)
Distilled water
Ethanol (optional, for washing)
Polyvinyl alcohol (PVA) or another stabilizer (optional)

Equipment Needed:
Magnetic stirrer and stirring bars
Ultrasonic bath or probe sonicator (for dispersing nanoparticles)
Beakers and flasks
Filtration apparatus (e.g,, filter paper and funnel)
Centrifuge (optional, for separating nanoparticles)
Drying oven or furnace (for drying)
Pipettes and graduated cylinders
pH meter (optional)

Procedure:

1. Preparation of Zinc Acetate Solution:
Weigh 9.12 grams of zinc acetate dihydrate.
Dissolve it in 100 mL of distilled water to make a 0.1 M solution. Stir the solution
until the zinc acetate is completely dissolved.

2. Preparation of Sodium Hydroxide Solution:
Weigh 8 grams of sodium hydroxide.
Dissolve it in 100 mL of distilled water to make a 0.2 M solution. Stir until fully
dissolved.

3. Synthesis of ZnO Nanoparticles:
Slowly add the sodium hydroxide solution to the zinc acetate solution while
stirring continuously. The addition should be gradual to ensure proper mixing
and formation of nanoparticles.
The mixture will initially become cloudy as zinc oxide forms. Stir the solution for
about 30 minutes at room temperature.

4. Aging and Stabilization:
Allow the mixture to age for 1-2 hours to ensure complete reaction. This step
helps in further formation and stabilization of nanoparticles.
If available, centrifuge the mixture at 3000 rpm for 15 minutes to separate the
nanoparticles from the solution. Collect the precipitate.
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5. Washing:
Wash the collected nanoparticles with distilled water several times to remove
any residual chemicals. If necessary, use ethanol for additional washing to
remove organic impurities.

6. Drying:
Transfer the washed nanoparticles to a drying oven set at 60°C. Dry for 6-8
hours, or until all moisture is evaporated. Alternatively, air dry if a furnace is not
available.

7. Characterization (Optional):
Use techniques such as UV-Vis spectroscopy to confirm the nanoparticle
formation. X-ray diffraction (XRD) can be used to determine the crystalline
structure.

Assignment for students
1. Explain the preparation of zinc oxide nanoparticles for use as a nano fertilizer.
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Exercise No. 12
Preparation of Nano Iron Oxide (Fe,03) Fertilizer

Objective: To synthesize iron oxide nanoparticles for use as a nano fertilizer.

Materials Required:
Iron chloride (FeCl3)
Sodium hydroxide (NaOH)
Distilled water
Ethanol (optional, for washing)

Equipment Needed:
Magnetic stirrer and stirring bars
Ultrasonic bath or probe sonicator
Beakers and flasks
Filtration apparatus
Centrifuge (optional)
Drying oven or furnace
pH meter (optional)

Procedure:

1. Preparation of Iron Chloride Solution:
Weigh 13.2 grams of iron chloride.
Dissolve in 100 mL of distilled water to prepare a 0.1 M solution. Stir until
completely dissolved.

2. Preparation of Sodium Hydroxide Solution:
Dissolve 8 grams of sodium hydroxide in 100 mL of distilled water to make a 0.2
M solution. Stir until fully dissolved.

3. Synthesis of Fe,03; Nanoparticles:
Slowly add the sodium hydroxide solution to the iron chloride solution while
stirring continuously.
A reddish-brown precipitate will form, indicating the formation of iron oxide
nanoparticles. Continue stirring for about 30 minutes.

4. Aging and Stabilization:
Allow the reaction mixture to age for 1-2 hours. This step helps in the
stabilization and further formation of nanoparticles.
If a centrifuge is available, centrifuge at 3000 rpm for 15 minutes. Collect the
precipitate.

5. Washing:
Wash the precipitate with distilled water and ethanol to remove residual
chemicals. Repeat washing until the supernatant is clear.
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6. Drying:
Dry the washed nanoparticles in an oven at 60°C for 6-8 hours. Alternatively, air
dry if a furnace is not available.

7. Characterization (Optional):
Confirm the formation of nanoparticles using UV-Vis spectroscopy or X-ray
diffraction (XRD).

Safety Considerations
Protective Gear: Always wear safety goggles, gloves, and lab coats to protect against
chemical spills and exposure.
Ventilation: Conduct experiments in a well-ventilated area or under a fume hood to
avoid inhaling fumes.
Handling Chemicals: Handle all chemicals carefully, following the safety data sheets
(SDS) and proper disposal procedures.

Assignment for students
1. Explain the preparation of iron oxide nanoparticles for use as a nano fertilizer.
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